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Le classi di documento in LyX
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© Perché LyX?
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classi di documento

@ LyX permette di concentrarsi sui contenuti. Impaginare il documento
finito & compito dei file di stile!

!I file .sty di latex definiscono una serie di tag al loro interno che in LyX compaiono
nel menu a tendina dei layout: alcuni sono standard, altri sono utilizzabili a seconda del
template scelto
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Le classi di documento

@ LyX permette di concentrarsi sui contenuti. Impaginare il documento
finito & compito dei file di stile!

@ In LyX esiste la classe documento che si "preoccupa” del tipo di
documento.

Trovate le classi che LyX offre nel menu:
Document > Settings > Document Class

!| file .sty di latex definiscono una serie di tag al loro interno che in LyX compaiono
nel menu a tendina dei layout: alcuni sono standard, altri sono utilizzabili a seconda del
template scelto
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Le classi di documento

@ LyX permette di concentrarsi sui contenuti. Impaginare il documento
finito & compito dei file di stile!

@ In LyX esiste la classe documento che si "preoccupa” del tipo di
documento.

Trovate le classi che LyX offre nel menu:
Document > Settings > Document Class

Alcuni esempi:

o Letter
@ ModernCV
@ Beamer

!| file .sty di latex definiscono una serie di tag al loro interno che in LyX compaiono
nel menu a tendina dei layout: alcuni sono standard, altri sono utilizzabili a seconda del
template scelto
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Keep in mind

@ LyX mette a disposizione una vasta scelta di Modelli pieni di note e
utili commenti

File > New from Template...
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Keep in mind

@ LyX mette a disposizione una vasta scelta di Modelli pieni di note e
utili commenti

File > New from Template...

beamer-conference-ornate-20min.lyx
letter.lyx

modernCV.lyx

slides.lyx

etc...
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Per chi vuole...

@ LyX permette anche di creare un layout su misura per un nuovo tipo
di documento
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Per chi vuole...

@ LyX permette anche di creare un layout su misura per un nuovo tipo
di documento

o E disponibile una guida accessibile andando su

Help > Customization
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© Classi di documento
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Per scrivere una lettera...

File > New from Template... > letter.lyx
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Per scrivere una lettera...

File > New from Template... > letter.lyx

Nota Bene

L'ultima riga di commiato, detta Signature, va inserita nel documento
prima del campo Opening, come specificato nel template

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 8 /36



...0 il ricettario della nonna *.*

File > New from Template... >
/usr/share/lyx/examples/recipebook.lyx
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...0 il ricettario della nonna *.*

File > New from Template... >
/usr/share/lyx/examples/recipebook.lyx

@ Compilare i campi a vostro piacimento
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...0 il ricettario della nonna *.*

File > New from Template... >
/usr/share/lyx/examples/recipebook.lyx

@ Compilare i campi a vostro piacimento

@ Esportare il file pdf!
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Per gli autori in erba...

@ LyX offre anche la modalitd Book?, piti precisamente

File > New

Document 1> Settings > Document Class > Book (Standard
Class)

2ma non offre nessun Template per tale modalita
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Per gli autori in erba...

@ LyX offre anche la modalitd Book?, piti precisamente

File > New

Document 1> Settings > Document Class > Book (Standard
Class)

@ In questo caso vengono molto utili strumenti come "Parte" o
"Capitolo"

2ma non offre nessun Template per tale modalita
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e per quelli di bestseller...

Ci vuole qualcosa «in piu»

@ Divide et Impera

Insert > File > Child Document...
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e per quelli di bestseller...

Ci vuole qualcosa «in piu»

@ Divide et Impera

Insert > File > Child Document...

o Citazioni

o E utile creare un ambiente bibliografia® con le fonti etichettate per riga

Insert > Citation...

3Per inserire la bibliografia andare su Insert > List/TOC > BibTgX Bibliography...
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e Modern CV
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Soltanto uno

Il pacchetto texlive-latex-extra® contiene ModernCV

“In ambienti GNU/Linux come Ubuntu, I'installazione di LyX include di
default anche il suddetto pacchetto

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 13 / 36


http://wiki.lyx.org/Examples/CV

Soltanto uno

Il pacchetto texlive-latex-extra® contiene ModernCV

“In ambienti GNU/Linux come Ubuntu, I'installazione di LyX include di
default anche il suddetto pacchetto

@ Potete trovare il template di esempio al seguente link
http://wiki.lyx.org/Examples/CV*

*aggiunge alcuni dati direttamente nel preambolo, per avere il template completo File
> New from Template... > .../examples/modernCV.lyx
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From CTAN

Comprehensive TEX Archive Network:

"Moderncv provides a document class for type setting
modern curricula vitae, both in a classic and in a casual style. It
is fairly customizable, allowing you to define your own style by
changing the colours, the fonts, etc."
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Scriviamo il nostro Curriculum

Oggi ci concentriamo sul template modernCV che ¢ il pil elegante e
gettonato.

File > New from Template... > .../examples/modernCV.lyx
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Scriviamo il nostro Curriculum

Oggi ci concentriamo sul template modernCV che ¢ il pil elegante e
gettonato.

File > New from Template... > .../examples/modernCV.lyx

o |l template offerto segue lo standard americano, che & privo dei campi
riguardanti i dati anagrafici

o inseribili comunque tramite il menu a tendina dei layout
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Scriviamo il nostro Curriculum

Oggi ci concentriamo sul template modernCV che ¢ il pil elegante e
gettonato.

File > New from Template... > .../examples/modernCV.lyx

o |l template offerto segue lo standard americano, che & privo dei campi
riguardanti i dati anagrafici

o inseribili comunque tramite il menu a tendina dei layout
Esistono altri template per creare il proprio CV:
o EuropeCV
o SimpleCV
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Example 1: Layout Item

@ |l layout Item consente di inserire testo su «riga continua»

e aggiungendo un Summary che riassume il contenuto

In LyX

Associatje
Item: uLMemher of Politecnico Open unix Labs (URL www.poul.org). 2014 — now. Promoting free

sOftwareCulture and related events.
@. hary CUS Milano Athlete of Politecnico di Bovisa - Soccer 5 (URL www.cusmilano.it). 2013 — now.
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Example 1: Layout Item

@ |l layout Item consente di inserire testo su «riga continua»

e aggiungendo un Summary che riassume il contenuto

In LyX

Associatje
Item: uLMemher of Politecnico Open unix Labs (URL www.poul.org). 2014 — now. Promoting free

sOftwareCulture and related events.
@. hary CUS Milano Athlete of Politecnico di Bovisa - Soccer 5 (URL www.cusmilano.it). 2013 — now.

In View

\ o ons

POuL. Member of Politecnico Open unix Labs (www.poul.org). 2014 — now.
Promoting free software culture and related events.

CUS Milano Athlete of Politecnico di Bovisa - Soccer 5 (www.cusmilano.it). 2013 —
now.
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Example 2: Layout Item with Comment

o Il layout Item with comment consente di inserire

e un Summary che riassume il contenuto...
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Example 2: Layout Item with Comment

o Il layout Item with comment consente di inserire

e un Summary che riassume il contenuto...

o ...del Text che lo riguarda
o e, volendo, del testo in pil

In LyX

omputer Skills

tem with Comment: /Summary @ Text ‘GNU/Linux, Windows‘g‘ood degree of knowledge
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Example 2: Layout Item with Comment

o Il layout Item with comment consente di inserire

e un Summary che riassume il contenuto...

o ...del Text che lo riguarda
o e, volendo, del testo in pil

In LyX

omputer Skills

tem with Comment: /Summary @ Text ‘GNU/Linux, Windows‘g‘ood degree of knowledge

In View

Computer S

OS GNU/Linux, Windows good degree of knowledge
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Example 3: Double Item

@ |l layout Double Item consente di inserire
e un Left Summary che riassume il contenuto a sinistra
@ un Left Text che riguarda il contenuto

o un Right Summary che riassume il contenuto a destra

In LyX

Double Item:) Left Summary Birth Place|Left Text Undefined| Right Summary Birth Datexx March 1992
ry
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Example 3: Double Item

@ |l layout Double Item consente di inserire
e un Left Summary che riassume il contenuto a sinistra
@ un Left Text che riguarda il contenuto

o un Right Summary che riassume il contenuto a destra

In LyX

Double Item:) Left Summary Birth Place|Left Text Undefined| Right Summary Birth Datexx March 1992

In View
A1 1
Birth Place Undefined Birth Date xx March 1992

Citizenship Bulgarian
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Per cambiare stile...

CVStyle dal menu a tendina dei layout

@ | possibili stili

casual (default)
classic

oldstyle
banking
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e perché no, colore...

CVColor dal menu a tendina dei layout

@ Tra i colori disponibili

blue (default)
orange

green

red

purple

gray

black
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Una feature carina

ModernCV permette di linkare i Social Network direttamente al file pdf
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Una feature carina

ModernCV permette di linkare i Social Network direttamente al file pdf

@ Per ora e possibile linkare solo

o linkedin
e github
o twitter
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Una feature carina

ModernCV permette di linkare i Social Network direttamente al file pdf

@ Per ora e possibile linkare solo

o linkedin
e github
o twitter

@ Ad esempio, per linkare Github:

o Dal menu a tendina selezionare Social
o Quindi Insert > Name

o Nella cella Name inserire il nome del Social tra quelli linkabili

o Inserire il proprio username di Github
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Una feature carina

ModernCV permette di linkare i Social Network direttamente al file pdf

@ Per ora e possibile linkare solo
o linkedin
e github
o twitter

@ Ad esempio, per linkare Github:

o Dal menu a tendina selezionare Social
o Quindi Insert > Name

o Nella cella Name inserire il nome del Social tra quelli linkabili

o Inserire il proprio username di Github

Importante
Per fare bene il link il nome del Social va inserito in lowercase

Adelina Doncheva
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And now is time for a...

Demo
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Sezione 4

@ Presentazioni
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Nulla di esilarante
L'unico requisito e aver installato il pacchetto IATEX contenente Beamer:

latex-beamer ?

“In ambienti GNU/Linux come Ubuntu, I'installazione di LyX include di
default anche il pacchetto richiesto
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Come si fanno le presentazioni in LyX?

o E sufficiente modificare la classe documento

Document 1> Settings > Document Class > Beamer

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 25 / 36



Come si fanno le presentazioni in LyX?

o E sufficiente modificare la classe documento

Document 1> Settings > Document Class > Beamer

@ Scegliere il Template

File > New from Template... >
beamer-conference-ornate-20min
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Come si fanno le presentazioni in LyX?

o E sufficiente modificare la classe documento

Document 1> Settings > Document Class > Beamer

@ Scegliere il Template

File > New from Template... >
beamer-conference-ornate-20min

@ Compilare i campi in base alle proprie esigenze e seguendo le comode
note
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Come si fanno le presentazioni in LyX?

o E sufficiente modificare la classe documento

Document 1> Settings > Document Class > Beamer

Scegliere il Template

File > New from Template... >
beamer-conference-ornate-20min

@ Compilare i campi in base alle proprie esigenze e seguendo le comode
note
o Generare il pdf! (Ctrl-R)
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Gerarchia del documento

Alcune note sull'importanza del gestire le gerarchie in modo corretto
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Gerarchia del documento

Alcune note sull'importanza del gestire le gerarchie in modo corretto

Per la Gerarchia
tab/shift-tab
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Gerarchia del documento

Alcune note sull'importanza del gestire le gerarchie in modo corretto

Per la Gerarchia Per evitare «conflitti» tra
tab/shift-tab Frame

Inserire il Separatore tra una
diapositiva e I'altra
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Gerarchia del documento

Alcune note sull'importanza del gestire le gerarchie in modo corretto

Per la Gerarchia Per evitare «conflitti» tra
tab/shift-tab Frame

Inserire il Separatore tra una
diapositiva e I'altra

Alt-P Enter l
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Le transizioni (aka pause)

Il concetto di animazione in LyX si realizza tramite le transizioni (o pause)

Definizione

La pausa & un elemento del contenuto che consente di separare cio che la
precede da cio che la segue.
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Le transizioni (aka pause)

Il concetto di animazione in LyX si realizza tramite le transizioni (o pause)

Definizione

La pausa & un elemento del contenuto che consente di separare cio che la
precede da cio che la segue.

Diapositiva Pause
“Frame Title .
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...ed ecco come funzionano

La pausa
Mantiene il filo logico e permette di far apparire
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La pausa
Mantiene il filo logico e permette di far apparire

@ un
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...ed ecco come funzionano

La pausa
Mantiene il filo logico e permette di far apparire

@ un

@ elemento
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...ed ecco come funzionano

La pausa
Mantiene il filo logico e permette di far apparire

@ un

@ elemento

e alla
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...ed ecco come funzionano

La pausa
Mantiene il filo logico e permette di far apparire

@ un

@ elemento

e alla

@ volta

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 28 / 36



| tre tipi di blocchi
Il blocco ha un titolo; il contenuto va inserito dopo il Block Title I
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tipi di blocchi

Informazione

Questo € un blocco informazione. E possibile inserire
@ un elenco
@ puntato

e all'interno del blocco
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| tre tipi di blocchi

| blocchi causano dipendenza: se ne utilizzate troppi potrebbe risultare
pesante per il lettore

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 29 / 36



Se volessimo cambiare tema alla nostra

presentazione?

@ Visitando https://www.hartwork.org/beamer-theme-matrix/
trovate i vari temi disponibili gia inclusi in LyX, senza la necessita di
scaricare nulla.

Potete quindi scegliere quello su misura per voil
o Ad ogni riga & stato assegnato il nome di una citta che rappresenta il

tema della presentazione
o Ogni colonna rappresenta il colore del tema
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Se volessimo cambiare tema alla nostra

presentazione?

@ Visitando https://www.hartwork.org/beamer-theme-matrix/
trovate i vari temi disponibili gia inclusi in LyX, senza la necessita di
scaricare nulla.

Potete quindi scegliere quello su misura per voil

o Ad ogni riga & stato assegnato il nome di una citta che rappresenta il
tema della presentazione
o Ogni colonna rappresenta il colore del tema

@ Una volta scelto il tema, & sufficiente...

Document > Settings > BTEX Preamble
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Se volessimo cambiare tema alla nostra

presentazione?

@ Visitando https://www.hartwork.org/beamer-theme-matrix/
trovate i vari temi disponibili gia inclusi in LyX, senza la necessita di
scaricare nulla.

Potete quindi scegliere quello su misura per voil

o Ad ogni riga & stato assegnato il nome di una citta che rappresenta il
tema della presentazione
o Ogni colonna rappresenta il colore del tema

@ Una volta scelto il tema, & sufficiente...

Document > Settings > BTEX Preamble
@ ...settare i parametri inserendoli nel preambolo

\usetheme{Madrid}
\usecolortheme{crane}
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Alcune feature dei footer

Per ogni tema & possibile scegliere il titolo da visualizzare sul footer
Come fare?
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Alcune feature dei footer

Per ogni tema & possibile scegliere il titolo da visualizzare sul footer
Come fare?

@ Ad esempio, scegliendo dal menu a tendina dei layout Title

Insert > Short Title
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Alcune feature dei footer

Per ogni tema & possibile scegliere il titolo da visualizzare sul footer
Come fare?

@ Ad esempio, scegliendo dal menu a tendina dei layout Title

Insert > Short Title

@ Per la Data scegliendo dal menu a tendina dei layout Date

Insert > Short Date
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Alcune feature dei footer

Per ogni tema & possibile scegliere il titolo da visualizzare sul footer
Come fare?

@ Ad esempio, scegliendo dal menu a tendina dei layout Title

Insert > Short Title

@ Per la Data scegliendo dal menu a tendina dei layout Date

Insert > Short Date

Per il campo Date LyX non si aspetta necessariamente una data l
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Demo
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Una carta vincente: versione stampabile

Per avere una versione stampabile della propria presentazione ¢ sufficiente
modificare la classe documento.

Document > Settings > Document Class > Beamer Article
(standard class)
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RTFM

Help > Specific Manuals > Beamer Presentations

e disponibile una guida sufficientemente completa sull’integrazione tra LyX
e Beamer.
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@ http://www.lyx.org/

@ http://ctan.mackichan.com/macros/latex/contrib/beamer/
doc/beameruserguide.pdf

@ https://www.poul.org/wp-content/uploads/2014/05/
LyX2014-presentazioni-cv.pdf

@ https://github.com/kodaline/Corso_Lyx_2015

Adelina Doncheva Corso LyX 2015 13 Aprile 2015 35 / 36


http://www.lyx.org/
http://ctan.mackichan.com/macros/latex/contrib/beamer/doc/beameruserguide.pdf
http://ctan.mackichan.com/macros/latex/contrib/beamer/doc/beameruserguide.pdf
https://www.poul.org/wp-content/uploads/2014/05/LyX2014-presentazioni-cv.pdf
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https://github.com/kodaline/Corso_Lyx_2015

Grazie per I'attenzione!

©00

Queste slides sono licenziate Creative Commons Attribution-ShareAlike 4.0

http://wuw.poul.org
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